Repairing Discovery 300TDI Auto Cruise Control

Just a quick guide here on repairing the most common problem with Discovery 300TDI Auto cruise control – the vacuum hose.  These rubber hoses seem to quite easily perforate or crack over time and it’s very easy to fix.  Firstly, if the cracks are small and near the joins just cut the hose and reconnect.  This only works if you have enough hose.  In my case the hose has already been cut too short and is actually just dangling in the engine bay.  So a quick trawl over to ebay found new silicon hose cheap enough.

I’ve purchased some silicon hose – 5m of 5mm internal diameter and 10mm outer.  This gives 2.5mm of wall which should be enough.   5m is overkill too, but it leaves about 1m for the toolbox.

Discovery 300TDI Auto Cruise Control Vacuum Hose - simple tools required

Tools required are very basic – a good knife, some pliers and some nice hot water.

First off, I’m starting at the auto speed controller unit thingy (I’m guessing there is a real name for this unit).  The hose here for me has already cut by a previous owner, but clearly this was too short and didn’t reach the t-piece.  So that’s a timely reminder to measure twice and cut once 🙂

So, taking the old hose off (very easily in my case), I use this to measure the length of new hose required.  Remembering in my case that the hose was too short, so I’ve added to the length (best to measure long and cut back later if your not sure).  Using the hot water to warm the silicon doesn’t seem to make any difference, but as a homage to the old rubber hoses and to make me feel better I’ve done it anyway.

Discovery 300TDI Auto Cruise Control Vacuum Hose - hot waterWith one end connected to the Auto unit, I warm the other end going to the t-peice.  Once connected up it’s time to look at the longer pipe.  Remove from the T around the bulkhead and into the aux battery/jack area.  Here the pipe dives under what would be the battery tray and into the pump.  The pump is not easy to see and whilst it can be removed, I’m not looking to waste time.

Drilling off the jack mounting plate to gain access to vacuum pump

 

So with that thought, I’ve drilled the rivets holding the pump base into place and removed.  This gives just enough access from the top to do the job and I can replace later if needed.  Removal of the old hose shows that it was completely perished and not even connected to the pump.

Now use this pipe to measure a new length – as always a bit longer is better and remember it can be cut back later.  I’m starting by connecting at the pump end.  On the right hand side of the pump are two projections – your aiming for the back one, slightly shorter.  Push it on as far as you can and give it a tug – it should be a secure fit.

Discovery 300TDI Auto Cruise Control Vacuum Hose - to the pump

 

The picture above shows the red silicon hose that I’m using and just visible through the left hold is part of the pump.  Now route the hose back around the bulkhead using the clips where available and trim if required at the t-piece.

Discovery 300TDI Auto Cruise Control Vacuum Hose - T piece connected

 

Connect to the t-piece and you should have replaced most of the hose.  There is one more that goes through the bulkhead into the drivers footwell, but this one is in good condition for me and I’m stopping at this point.    So final picture from me shows a little more of the engine bay and the new red silicone hose.

Discovery 300TDI Auto Cruise Control Vacuum Hose - complete

 

So did it fix the problem… oh yea 🙂  fully working Cruise Control now on my 300TDI Auto!  Simple fix and only 10 mins of my day used.

Just found a nice guide to the rest of the system – it can be found on Landyzone here.

 

Creative Commons License
Repairing Discovery 300TDI Auto Cruise Control by Adrian Hollister is licensed under a Creative Commons Attribution-ShareAlike 4.0 International

Want to say something interesting?